summaryrefslogtreecommitdiffstats
path: root/4lib/krebs/types.nix
diff options
context:
space:
mode:
Diffstat (limited to '4lib/krebs/types.nix')
-rw-r--r--4lib/krebs/types.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/4lib/krebs/types.nix b/4lib/krebs/types.nix
index 38ed8a916..ca92c6900 100644
--- a/4lib/krebs/types.nix
+++ b/4lib/krebs/types.nix
@@ -20,6 +20,15 @@ types // rec {
type = attrsOf net;
apply = x: assert hasAttr "retiolum" x; x;
};
+ secure = mkOption {
+ type = bool;
+ default = false;
+ description = ''
+ If true, then the host is capable of keeping secret information.
+
+ TODO define minimum requirements for secure hosts
+ '';
+ };
};
};
@@ -72,6 +81,17 @@ types // rec {
merge = mergeOneOption;
};
+ user = submodule {
+ options = {
+ name = mkOption {
+ type = str; # TODO
+ };
+ pubkey = mkOption {
+ type = str;
+ };
+ };
+ };
+
# TODO
addr = str;
addr4 = str;
[cgit] Unable to lock slot /tmp/cgit/12000000.lock: No such file or directory (2)