summaryrefslogtreecommitdiffstats
path: root/4lib/krebs/types.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-24 21:04:22 +0200
committermakefu <github@syntax-fehler.de>2015-07-24 21:04:22 +0200
commite1f4ef731f34056c8360de8be21c2bfbc396d2e4 (patch)
treea960212d1ee8b0666ebb934c383816900d45cc7a /4lib/krebs/types.nix
parent7d71db1eb0ce36f8be914f53412615eba0090747 (diff)
parenta62be1cef8726a2afa61df3dac9e19a71882b370 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to '4lib/krebs/types.nix')
-rw-r--r--4lib/krebs/types.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/4lib/krebs/types.nix b/4lib/krebs/types.nix
index 38ed8a916..ca92c6900 100644
--- a/4lib/krebs/types.nix
+++ b/4lib/krebs/types.nix
@@ -20,6 +20,15 @@ types // rec {
type = attrsOf net;
apply = x: assert hasAttr "retiolum" x; x;
};
+ secure = mkOption {
+ type = bool;
+ default = false;
+ description = ''
+ If true, then the host is capable of keeping secret information.
+
+ TODO define minimum requirements for secure hosts
+ '';
+ };
};
};
@@ -72,6 +81,17 @@ types // rec {
merge = mergeOneOption;
};
+ user = submodule {
+ options = {
+ name = mkOption {
+ type = str; # TODO
+ };
+ pubkey = mkOption {
+ type = str;
+ };
+ };
+ };
+
# TODO
addr = str;
addr4 = str;
[cgit] Unable to lock slot /tmp/cgit/38100000.lock: No such file or directory (2)