summaryrefslogtreecommitdiffstats
path: root/modules/lass/games.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/lass/games.nix')
-rw-r--r--modules/lass/games.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/lass/games.nix b/modules/lass/games.nix
new file mode 100644
index 000000000..d48c484da
--- /dev/null
+++ b/modules/lass/games.nix
@@ -0,0 +1,22 @@
+{ config, pkgs, ... }:
+
+{
+ environment.systemPackages = with pkgs; [
+ dwarf_fortress
+ ];
+
+ users.extraUsers = {
+ games = {
+ name = "games";
+ description = "user playing games";
+ home = "/home/games";
+ extraGroups = [ "audio" ];
+ createHome = true;
+ useDefaultShell = true;
+ };
+ };
+
+ security.sudo.extraConfig = ''
+ lass ALL=(games) NOPASSWD: ALL
+ '';
+}