summaryrefslogtreecommitdiffstats
path: root/modules/lass/games.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-04-10 01:37:29 +0200
committertv <tv@shackspace.de>2015-05-19 23:17:19 +0200
commitaa5d113f90c29f483aa679738dc52e5df1763fec (patch)
tree9be801304c8331bc211ad738836b3f3a03e74cea /modules/lass/games.nix
parent6593d16308109ded64d5c842d6a12c4106767df4 (diff)
mors: import mors + config
Diffstat (limited to 'modules/lass/games.nix')
-rw-r--r--modules/lass/games.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/lass/games.nix b/modules/lass/games.nix
new file mode 100644
index 000000000..d48c484da
--- /dev/null
+++ b/modules/lass/games.nix
@@ -0,0 +1,22 @@
+{ config, pkgs, ... }:
+
+{
+ environment.systemPackages = with pkgs; [
+ dwarf_fortress
+ ];
+
+ users.extraUsers = {
+ games = {
+ name = "games";
+ description = "user playing games";
+ home = "/home/games";
+ extraGroups = [ "audio" ];
+ createHome = true;
+ useDefaultShell = true;
+ };
+ };
+
+ security.sudo.extraConfig = ''
+ lass ALL=(games) NOPASSWD: ALL
+ '';
+}
[cgit] Unable to lock slot /tmp/cgit/6e200000.lock: No such file or directory (2)