summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/default.nix')
-rw-r--r--krebs/5pkgs/default.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/krebs/5pkgs/default.nix b/krebs/5pkgs/default.nix
index a8a1b5853..84fb8725b 100644
--- a/krebs/5pkgs/default.nix
+++ b/krebs/5pkgs/default.nix
@@ -1,6 +1,6 @@
-{ lib, pkgs, ... }:
+{ pkgs, ... }:
-with import ../4lib { inherit lib; };
+with import ../4lib { inherit (pkgs) lib; };
let
subdirs = mapAttrs (_: flip pkgs.callPackage {}) (subdirsOf ./.);
@@ -9,6 +9,20 @@ in
subdirs // rec {
+ haskellPackages = pkgs.haskellPackages.override {
+ overrides = self: super:
+ mapAttrs (name: path: self.callPackage path {})
+ (mapAttrs'
+ (name: type:
+ if hasSuffix ".nix" name
+ then {
+ name = removeSuffix ".nix" name;
+ value = ./haskell-overrides + "/${name}";
+ }
+ else null)
+ (builtins.readDir ./haskell-overrides));
+ };
+
push = pkgs'.callPackage ./push {
inherit (subdirs) get jq;
};
@@ -30,7 +44,7 @@ subdirs // rec {
execveBin = name: cfg: execve name (cfg // { destination = "/bin/${name}"; });
writeC = name: { destination ? "" }: src: pkgs.runCommand name {} ''
- PATH=${lib.makeSearchPath "bin" (with pkgs; [
+ PATH=${makeSearchPath "bin" (with pkgs; [
binutils
coreutils
gcc
[cgit] Unable to lock slot /tmp/cgit/6b000000.lock: No such file or directory (2)