summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-10-17 11:18:55 +0200
committermakefu <github@syntax-fehler.de>2015-10-17 11:18:55 +0200
commit2454867a529ab44f22c9e1c51e3642ac4c391bad (patch)
treeaa0aa4d81cd95046cce98ff770642f6c21fb31b2 /krebs/5pkgs/default.nix
parentf83b3770dd401004bef0233c3de0eb07686788a5 (diff)
parent4d32e1575705e544c8cbb5834447d71c1b577970 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/5pkgs/default.nix')
-rw-r--r--krebs/5pkgs/default.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/krebs/5pkgs/default.nix b/krebs/5pkgs/default.nix
index a8a1b5853..84fb8725b 100644
--- a/krebs/5pkgs/default.nix
+++ b/krebs/5pkgs/default.nix
@@ -1,6 +1,6 @@
-{ lib, pkgs, ... }:
+{ pkgs, ... }:
-with import ../4lib { inherit lib; };
+with import ../4lib { inherit (pkgs) lib; };
let
subdirs = mapAttrs (_: flip pkgs.callPackage {}) (subdirsOf ./.);
@@ -9,6 +9,20 @@ in
subdirs // rec {
+ haskellPackages = pkgs.haskellPackages.override {
+ overrides = self: super:
+ mapAttrs (name: path: self.callPackage path {})
+ (mapAttrs'
+ (name: type:
+ if hasSuffix ".nix" name
+ then {
+ name = removeSuffix ".nix" name;
+ value = ./haskell-overrides + "/${name}";
+ }
+ else null)
+ (builtins.readDir ./haskell-overrides));
+ };
+
push = pkgs'.callPackage ./push {
inherit (subdirs) get jq;
};
@@ -30,7 +44,7 @@ subdirs // rec {
execveBin = name: cfg: execve name (cfg // { destination = "/bin/${name}"; });
writeC = name: { destination ? "" }: src: pkgs.runCommand name {} ''
- PATH=${lib.makeSearchPath "bin" (with pkgs; [
+ PATH=${makeSearchPath "bin" (with pkgs; [
binutils
coreutils
gcc
[cgit] Unable to lock slot /tmp/cgit/40100000.lock: No such file or directory (2)