summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/x220.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/hw/x220.nix')
-rw-r--r--tv/2configs/hw/x220.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/tv/2configs/hw/x220.nix b/tv/2configs/hw/x220.nix
index 8c68cdef0..ee3c7dc04 100644
--- a/tv/2configs/hw/x220.nix
+++ b/tv/2configs/hw/x220.nix
@@ -1,7 +1,5 @@
-{ config, pkgs, ... }: let
- lib = import <stockholm/lib>;
-in
-{
+with import ./lib;
+{ config, pkgs, ... }: {
imports = [
../smartd.nix
{
@@ -28,8 +26,8 @@ in
}
{
- nix.buildCores = 2;
- nix.maxJobs = 2;
+ nix.settings.cores = 2;
+ nix.settings.max-jobs = 2;
}
(if lib.versionAtLeast (lib.versions.majorMinor lib.version) "21.11" then {
nix.daemonCPUSchedPolicy = "batch";
@@ -61,6 +59,9 @@ in
emulateWheel = true;
};
+ # Conflicts with TLP, but gets enabled by DEs.
+ services.power-profiles-daemon.enable = false;
+
services.tlp.enable = true;
services.tlp.settings = {
START_CHARGE_THRESH_BAT0 = 80;