summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/otpauth/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/otpauth/default.nix')
-rw-r--r--makefu/5pkgs/otpauth/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/makefu/5pkgs/otpauth/default.nix b/makefu/5pkgs/otpauth/default.nix
new file mode 100644
index 000000000..2d96b315d
--- /dev/null
+++ b/makefu/5pkgs/otpauth/default.nix
@@ -0,0 +1,24 @@
+{ lib, fetchFromGitHub, buildGoModule, ... }:
+ buildGoModule rec {
+ pname = "otpauth";
+ version = "0.3.2";
+
+ src = fetchFromGitHub {
+ owner = "dim13";
+ repo = "otpauth";
+ rev = "v${version}";
+ sha256 = "1q6byb87cyvm4prildfcr8qc283ikvz5zazm92jk19qhav6ywj65";
+ };
+
+ vendorSha256 = "0lhxc855lr0mzq35i0s2xkcd4qa74yks6ypi80ij9ia0x1hdf1dq";
+
+ runVend = false;
+
+ meta = with lib; {
+ description = "Google Authenticator migration decoder";
+ homepage = "https://github.com/dim13/otpauth";
+ license = licenses.isc;
+ maintainers = with maintainers; [ makefu ];
+ platforms = platforms.linux ++ platforms.darwin;
+ };
+}