summaryrefslogtreecommitdiffstats
path: root/lass/3modules/pyload.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/3modules/pyload.nix')
-rw-r--r--lass/3modules/pyload.nix55
1 files changed, 0 insertions, 55 deletions
diff --git a/lass/3modules/pyload.nix b/lass/3modules/pyload.nix
deleted file mode 100644
index 6f29ffb17..000000000
--- a/lass/3modules/pyload.nix
+++ /dev/null
@@ -1,55 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-
-let
- cfg = config.lass.pyload;
-
- out = {
- options.lass.pyload = api;
- config = lib.mkIf cfg.enable imp;
- };
-
- api = {
- enable = mkEnableOption "pyload";
- user = mkOption {
- type = types.str;
- default = "download";
- };
- };
-
- imp = {
-
- krebs.per-user.${cfg.user}.packages = [
- pkgs.pyload
- pkgs.spidermonkey
- pkgs.tesseract
- ];
-
- krebs.iptables.tables.filter.INPUT.rules = [
- { predicate = "-p tcp --dport 9099"; target = "ACCEPT"; }
- ];
- systemd.services.pyload = {
- description = "pyload";
- after = [ "network.target" ];
- wantedBy = [ "multi-user.target" ];
-
- path = with pkgs; [
- pyload
- spidermonkey
- tesseract
- dnsmasq
- ];
-
- restartIfChanged = true;
-
- serviceConfig = {
- Restart = "always";
- ExecStart = "${pkgs.pyload}/bin/pyLoadCore";
- User = cfg.user;
- };
- };
-
- };
-
-in out
[cgit] Unable to lock slot /tmp/cgit/77200000.lock: No such file or directory (2)