summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/reaktor.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/shack/reaktor.nix')
-rw-r--r--krebs/2configs/shack/reaktor.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/krebs/2configs/shack/reaktor.nix b/krebs/2configs/shack/reaktor.nix
index 40c121299..a31c7a687 100644
--- a/krebs/2configs/shack/reaktor.nix
+++ b/krebs/2configs/shack/reaktor.nix
@@ -16,4 +16,15 @@
}
];
};
+ systemd.services.announce_doorstatus = {
+ startAt = "*:0/1";
+ path = with pkgs; [ curl jq ];
+ script = builtins.readFile ./doorstatus.sh;
+ serviceConfig = {
+ DynamicUser = true;
+ StateDirectory = "doorstatus";
+ WorkingDirectory = "/var/lib/doorstatus";
+ PrivateTmp = true;
+ };
+ };
}