summaryrefslogtreecommitdiffstats
path: root/lass/kops.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-04-05 23:21:53 +0200
committermakefu <github@syntax-fehler.de>2018-04-05 23:21:53 +0200
commit54c104e1e1f59906ddf855d6993de14d07a093dc (patch)
treecc271ff3806fac4176997a1e51ef03b454e1a6e4 /lass/kops.nix
parent241973f2ec1f4fcf217c37fd102feba82bc0b66e (diff)
parent1dd03483619d00d1afc6a278ded0cca6cff2d9ed (diff)
Merge remote-tracking branch 'lass/master' into stagingstaging
Diffstat (limited to 'lass/kops.nix')
-rw-r--r--lass/kops.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/lass/kops.nix b/lass/kops.nix
new file mode 100644
index 000000000..9d0ab911a
--- /dev/null
+++ b/lass/kops.nix
@@ -0,0 +1,35 @@
+{ name }: let
+ inherit (import ../krebs/kops.nix { inherit name; })
+ krebs-source
+ lib
+ pkgs
+ ;
+
+ source = { test }: lib.evalSource [
+ krebs-source
+ {
+ nixos-config.symlink = "stockholm/lass/1systems/${name}/config.nix";
+ secrets = if test then {
+ file = "/home/lass/stockholm/lass/2configs/tests/dummy-secrets";
+ } else {
+ pass = {
+ dir = "${lib.getEnv "HOME"}/.password-store";
+ name = "hosts/${name}";
+ };
+ };
+ }
+ ];
+
+in {
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A deploy)
+ deploy = pkgs.kops.writeDeploy "${name}-deploy" {
+ source = source { test = false; };
+ target = "root@${name}/var/src";
+ };
+
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A test)
+ test = pkgs.kops.writeTest "${name}-test" {
+ source = source { test = true; };
+ target = "${lib.getEnv "HOME"}/tmp/${name}-kops-test-src";
+ };
+}