summaryrefslogtreecommitdiffstats
path: root/lass/3modules/pyload.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-06-01 10:08:56 +0200
committermakefu <github@syntax-fehler.de>2017-06-01 10:08:56 +0200
commit772f84305d90380e0d221cf49ae3f1597d0d0510 (patch)
tree8d2241648396dc34fa96c8c68e12f832fbc7c308 /lass/3modules/pyload.nix
parent90822f64e0bf247c5cca2f035077553cac5ceb79 (diff)
parent21d92086fe00c7369fde3951f92e9f73f4c05ee9 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/3modules/pyload.nix')
-rw-r--r--lass/3modules/pyload.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/lass/3modules/pyload.nix b/lass/3modules/pyload.nix
new file mode 100644
index 000000000..6f29ffb17
--- /dev/null
+++ b/lass/3modules/pyload.nix
@@ -0,0 +1,55 @@
+{ config, lib, pkgs, ... }:
+
+with import <stockholm/lib>;
+
+let
+ cfg = config.lass.pyload;
+
+ out = {
+ options.lass.pyload = api;
+ config = lib.mkIf cfg.enable imp;
+ };
+
+ api = {
+ enable = mkEnableOption "pyload";
+ user = mkOption {
+ type = types.str;
+ default = "download";
+ };
+ };
+
+ imp = {
+
+ krebs.per-user.${cfg.user}.packages = [
+ pkgs.pyload
+ pkgs.spidermonkey
+ pkgs.tesseract
+ ];
+
+ krebs.iptables.tables.filter.INPUT.rules = [
+ { predicate = "-p tcp --dport 9099"; target = "ACCEPT"; }
+ ];
+ systemd.services.pyload = {
+ description = "pyload";
+ after = [ "network.target" ];
+ wantedBy = [ "multi-user.target" ];
+
+ path = with pkgs; [
+ pyload
+ spidermonkey
+ tesseract
+ dnsmasq
+ ];
+
+ restartIfChanged = true;
+
+ serviceConfig = {
+ Restart = "always";
+ ExecStart = "${pkgs.pyload}/bin/pyLoadCore";
+ User = cfg.user;
+ };
+ };
+
+ };
+
+in out