summaryrefslogtreecommitdiffstats
path: root/lass/1systems/helios/config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-18 21:24:28 +0100
committermakefu <github@syntax-fehler.de>2017-12-18 21:24:28 +0100
commitaf308642031f971bc30c5694385eb7af1e9ea618 (patch)
tree7e9e55f7d5de874a61a5d9294065a4f9749ee83e /lass/1systems/helios/config.nix
parent4feafd70204f9c13500bd427d250fac60ca595ef (diff)
parent676c76dd8e0b5cbe3d1bdba49b21b1b5cfc578a1 (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'lass/1systems/helios/config.nix')
-rw-r--r--lass/1systems/helios/config.nix33
1 files changed, 21 insertions, 12 deletions
diff --git a/lass/1systems/helios/config.nix b/lass/1systems/helios/config.nix
index b14ef2a3e..8bd9735a9 100644
--- a/lass/1systems/helios/config.nix
+++ b/lass/1systems/helios/config.nix
@@ -20,20 +20,26 @@ with import <stockholm/lib>;
boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
boot.kernelModules = [ "kvm-intel" ];
- fileSystems."/" =
- { device = "/dev/pool/root";
- fsType = "btrfs";
- };
+ fileSystems."/" = {
+ device = "/dev/pool/root";
+ fsType = "btrfs";
+ };
+
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/1F60-17C6";
+ fsType = "vfat";
+ };
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/1F60-17C6";
- fsType = "vfat";
- };
+ fileSystems."/home" = {
+ device = "/dev/pool/home";
+ fsType = "btrfs";
+ };
- fileSystems."/home" =
- { device = "/dev/pool/home";
- fsType = "btrfs";
- };
+ fileSystems."/tmp" = {
+ device = "tmpfs";
+ fsType = "tmpfs";
+ options = ["nosuid" "nodev" "noatime"];
+ };
nix.maxJobs = lib.mkDefault 8;
}
@@ -150,4 +156,7 @@ with import <stockholm/lib>;
services.printing.drivers = [ pkgs.postscript-lexmark ];
+ services.logind.extraConfig = ''
+ HandleLidSwitch=ignore
+ '';
}
[cgit] Unable to lock slot /tmp/cgit/ac100000.lock: No such file or directory (2)