summaryrefslogtreecommitdiffstats
path: root/lass/1systems/echelon/physical.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-09-11 14:55:04 +0200
committertv <tv@krebsco.de>2023-09-11 14:55:04 +0200
commit8fc162ee3d9525a2b45346a1ca8f34ccb5ef971b (patch)
treeaa37724dd0452860d4b9b033332587c8832629e3 /lass/1systems/echelon/physical.nix
parent90b1515dcd5b67a85cd92901fb211764b1fa5f83 (diff)
parent083229d0211096daec08673f743ccc45b1d8a0ac (diff)
Merge remote-tracking branch 'orange/master'
Diffstat (limited to 'lass/1systems/echelon/physical.nix')
-rw-r--r--lass/1systems/echelon/physical.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/lass/1systems/echelon/physical.nix b/lass/1systems/echelon/physical.nix
deleted file mode 100644
index fbacc3927..000000000
--- a/lass/1systems/echelon/physical.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{ config, lib, pkgs, modulesPath, ... }:
-{
- imports = [
- ./config.nix
- (modulesPath + "/profiles/qemu-guest.nix")
- ];
-
- # Use the GRUB 2 boot loader.
- boot.loader.grub.enable = true;
- boot.loader.grub.version = 2;
- boot.loader.grub.efiSupport = true;
- boot.loader.grub.efiInstallAsRemovable = true;
- # Define on which hard drive you want to install Grub.
- boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
-
- boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "sd_mod" "sr_mod" ];
- boot.initrd.kernelModules = [ "dm-snapshot" ];
- boot.initrd.luks.devices.luksroot.device = "/dev/sda3";
-
- networking.useDHCP = false;
- networking.interfaces.ens18.useDHCP = true;
-
- fileSystems."/" = {
- device = "/dev/disk/by-uuid/5186edb1-9234-48ae-8679-61facb56b818";
- fsType = "xfs";
- };
-
- fileSystems."/boot" = {
- device = "/dev/disk/by-uuid/56D1-34A0";
- fsType = "vfat";
- };
-
-}