summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/security-workarounds.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2022-12-12 19:44:00 +0100
committermakefu <github@syntax-fehler.de>2022-12-12 19:44:00 +0100
commit6eb5e44b7e5bdc8b1b3b5ffe40c146841f7afd10 (patch)
treef706bf7c3c7a289f680ac329caa2b578e5145a56 /krebs/2configs/security-workarounds.nix
parent96e934dc8a353cff91ef824f6a125ed49996d058 (diff)
parent3884243448869bdf09f6434b385e532c7c26ae88 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'krebs/2configs/security-workarounds.nix')
-rw-r--r--krebs/2configs/security-workarounds.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/krebs/2configs/security-workarounds.nix b/krebs/2configs/security-workarounds.nix
index 74a77a0ed..cb5d236ac 100644
--- a/krebs/2configs/security-workarounds.nix
+++ b/krebs/2configs/security-workarounds.nix
@@ -4,10 +4,15 @@
nixpkgs.overlays = [
(self: super: {
exim =
- super.exim.overrideAttrs (old: {
+ super.exim.overrideAttrs (old: let
+ key = if builtins.hasAttr "preBuild" old then
+ "preBuild"
+ else
+ "configurePhase";
+ in {
buildInputs = old.buildInputs ++ [ self.gnutls ];
- preBuild = /* sh */ ''
- ${old.preBuild}
+ ${key} = /* sh */ ''
+ ${old.${key}}
sed -Ei '
s:^USE_OPENSSL=.*:# &:
s:^# (USE_GNUTLS)=.*:\1=yes: