summaryrefslogtreecommitdiffstats
path: root/nix/python-matrixbot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/python-matrixbot.nix')
-rw-r--r--nix/python-matrixbot.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nix/python-matrixbot.nix b/nix/python-matrixbot.nix
new file mode 100644
index 0000000..7bc5aa7
--- /dev/null
+++ b/nix/python-matrixbot.nix
@@ -0,0 +1,31 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, markdown
+, matrix-client
+}:
+
+buildPythonPackage rec {
+ pname = "python-matrixbot";
+ version = "0.0.7";
+ CI_COMMIT_TAG = version;
+
+ #src = ./python-matrixbot;
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "9412981b14ff3ab7ffbb1bfc1691758113ab8d71f731b3093d8808c286b69c71";
+ };
+ patches = [ ./matrixbot.patch ];
+
+ propagatedBuildInputs = [
+ markdown
+ matrix-client
+ ];
+
+ meta = with lib; {
+ description = "A basic bot for Matrix";
+ homepage = https://gitlab.com/gibberfish/python-matrixbot;
+ license = licenses.mit;
+ # maintainers = [ maintainers. ];
+ };
+}