summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-08-15 14:26:57 +0200
committermakefu <github@syntax-fehler.de>2020-08-15 14:26:57 +0200
commit6413ce746978cac7ed666f455a57680b299dc7f2 (patch)
tree8b757f713b7e0dcfc4a32bb3ef249912e8c33729 /setup.py
parent6ca24980fd9aef34ace440ec683eed81a22ca6a8 (diff)
init setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..b090ad7
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,28 @@
+from setuptools import setup
+
+setup(
+ name="kalauerbot",
+ description="Bot for managing the Kalauer König",
+ version="1.0.0",
+ packages=["kalauerbot"],
+ license="MIT",
+ long_description=open("README.md").read(),
+ author="Felix Richter",
+ author_email="github@krebsco.de",
+ install_requires=[
+ "python-matrixbot",
+ "googletrans",
+ ],
+ entry_points={"console_scripts": [
+ "kalauerbot = kalauerbot.bot:main"
+ ]},
+ classifiers=[
+ "Intended Audience :: Human",
+ "Natural Language :: English",
+ "Operating System :: POSIX :: Linux",
+ "Development Status :: 3 - Alpha",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: Implementation :: CPython",
+ ],
+)