summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-03-11 09:22:58 +0100
committermakefu <github@syntax-fehler.de>2020-03-11 09:26:51 +0100
commit1ab0949f9d8e97aafafbd347a625fd97eeaa48a3 (patch)
treebafe9c821463eb71d7944a2d9cf85082a9c6481e /shell.nix
parenta19ccf35dc0b01a509c88c8b66c79aa0d2a986b4 (diff)
init project setup
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..79beb8a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,25 @@
+let
+ # Look here for information about how to generate `nixpkgs-version.json`.
+ # → https://nixos.wiki/wiki/FAQ/Pinning_Nixpkgs
+ pinnedVersion = builtins.fromJSON (builtins.readFile ./.nixpkgs-version.json);
+ pinnedPkgs = import (builtins.fetchGit {
+ inherit (pinnedVersion) url rev;
+
+ ref = "nixos-unstable";
+ }) {};
+in
+
+# This allows overriding pkgs by passing `--arg pkgs ...`
+{ pkgs ? pinnedPkgs }:
+
+with pkgs.python3.pkgs;
+buildPythonPackage {
+ name = "env";
+ src = ./.;
+ propagatedBuildInputs = [
+ docopt
+ requests
+ beautifulsoup4
+ ];
+ checkInputs = [ black jq ];
+}