summaryrefslogtreecommitdiffstats
path: root/old/modules/uriel/retiolum.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/uriel/retiolum.nix')
-rw-r--r--old/modules/uriel/retiolum.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/old/modules/uriel/retiolum.nix b/old/modules/uriel/retiolum.nix
new file mode 100644
index 000000000..1e90083fc
--- /dev/null
+++ b/old/modules/uriel/retiolum.nix
@@ -0,0 +1,31 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ../tv/retiolum
+ ../lass/iptables
+ ];
+
+ tv.retiolum = {
+ enable = true;
+ hosts = ../../hosts;
+ privateKeyFile = "/etc/nixos/secrets/uriel.retiolum.rsa_key.priv";
+ connectTo = [
+ "fastpoke"
+ "gum"
+ "ire"
+ ];
+ };
+
+ #networking.firewall.allowedTCPPorts = [ 655 ];
+ #networking.firewall.allowedUDPPorts = [ 655 ];
+ #lass.iptables = {
+ # #input-internet-accept-new-tcp = [ "tinc" ];
+ # #input-internet-accept-new-udp = [ "tinc" ];
+ # tables.retiolum = {
+ # interfaces = [ "retiolum" "wl0" ];
+ # allowed-tcp = [ "tinc" ];
+ # allowed-udp = [ "tinc" ];
+ # };
+ #};
+}
[cgit] Unable to lock slot /tmp/cgit/74100000.lock: No such file or directory (2)