summaryrefslogtreecommitdiffstats
path: root/nin/2configs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nin/2configs/default.nix')
-rw-r--r--nin/2configs/default.nix17
1 files changed, 15 insertions, 2 deletions
diff --git a/nin/2configs/default.nix b/nin/2configs/default.nix
index e181a6041..a1ed76d98 100644
--- a/nin/2configs/default.nix
+++ b/nin/2configs/default.nix
@@ -46,6 +46,12 @@ with import <stockholm/lib>;
SSL_CERT_FILE = ca-bundle;
};
})
+ {
+ nix = {
+ binaryCaches = ["http://cache.prism.r"];
+ binaryCachePublicKeys = ["cache.prism-1:+S+6Lo/n27XEtvdlQKuJIcb1yO5NUqUCE2lolmTgNJU="];
+ };
+ }
];
networking.hostName = config.krebs.build.host.name;
@@ -58,7 +64,10 @@ with import <stockholm/lib>;
user = config.krebs.users.nin;
source = let inherit (config.krebs.build) host; in {
nixos-config.symlink = "stockholm/nin/1systems/${host.name}.nix";
- secrets.file = "/home/nin/secrets/${host.name}";
+ secrets.file =
+ if getEnv "dummy_secrets" == "true"
+ then toString <stockholm/nin/6tests/dummysecrets>
+ else "/home/nin/secrets/${host.name}";
stockholm.file = getEnv "PWD";
};
};
@@ -82,11 +91,14 @@ with import <stockholm/lib>;
# multiple-definition-problem when defining environment.variables.EDITOR
environment.extraInit = ''
EDITOR=vim
- MANPAGER=most
'';
nixpkgs.config.allowUnfree = true;
+ environment.shellAliases = {
+ gs = "git status";
+ };
+
environment.systemPackages = with pkgs; [
#stockholm
git
@@ -95,6 +107,7 @@ with import <stockholm/lib>;
proot
populate
p7zip
+ termite
unzip
unrar
hashPassword
[cgit] Unable to lock slot /tmp/cgit/cb100000.lock: No such file or directory (2)