summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/docker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/home/ham/docker.nix')
-rw-r--r--makefu/2configs/home/ham/docker.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/makefu/2configs/home/ham/docker.nix b/makefu/2configs/home/ham/docker.nix
new file mode 100644
index 000000000..e8a47dbbb
--- /dev/null
+++ b/makefu/2configs/home/ham/docker.nix
@@ -0,0 +1,30 @@
+{ config, pkgs, lib, ... }:
+let
+ confdir = "/var/lib/homeassistant-docker";
+in {
+ imports = [
+ ./nginx.nix
+ ./mqtt.nix
+ ./signal-rest
+ ./signal-rest/service.nix
+ ];
+
+ networking.firewall.allowedTCPPorts = [ 8123 ];
+ state = [ "/var/lib/hass/known_devices.yaml" ];
+ virtualisation.oci-containers.containers.hass = {
+ image = "homeassistant/home-assistant:latest";
+ environment = {
+ TZ = "Europe/Berlin";
+ UMASK = "007";
+ };
+ extraOptions = ["--net=host" ];
+ volumes = [
+ "${confdir}:/config"
+ #"/data/music:/config/media"
+ ];
+ };
+ systemd.tmpfiles.rules = [
+ #"f ${confdir}/docker-run 0770 kiosk kiosk - -"
+ "d ${confdir} 0770 kiosk kiosk - -"
+ ];
+}