summaryrefslogtreecommitdiffstats
path: root/lib/pure.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/pure.nix')
-rw-r--r--lib/pure.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/pure.nix b/lib/pure.nix
index bb2d586f6..3329db022 100644
--- a/lib/pure.nix
+++ b/lib/pure.nix
@@ -26,7 +26,7 @@ let
krops = import ../submodules/krops/lib;
shell = import ./shell.nix { inherit (stockholm) lib; };
systemd = {
- encodeName = replaceChars ["/"] ["\\x2f"];
+ encodeName = replaceStrings ["/"] ["\\x2f"];
};
types = nixpkgs-lib.types // import ./types.nix { lib = stockholm.lib; };
uri = import ./uri.nix { inherit (stockholm) lib; };
@@ -79,7 +79,7 @@ let
string = toJSON x; # close enough
}.${type} or reject;
- indent = replaceChars ["\n"] ["\n "];
+ indent = replaceStrings ["\n"] ["\n "];
stripAttr = converge (filterAttrsRecursive (n: v: v != {} && v != null));