summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 574713e48..94a81439e 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -52,6 +52,7 @@ let
type = typeOf x;
reject = throw "cannot convert ${type}";
in {
+ int = toJSON x; # close enough
list = "{ ${concatStringsSep ", " (map toC x)} }";
null = "NULL";
set = if isDerivation x then toJSON x else reject;