summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/hashPassword/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/hashPassword/default.nix')
-rw-r--r--krebs/5pkgs/hashPassword/default.nix15
1 files changed, 0 insertions, 15 deletions
diff --git a/krebs/5pkgs/hashPassword/default.nix b/krebs/5pkgs/hashPassword/default.nix
deleted file mode 100644
index 3da65ad79..000000000
--- a/krebs/5pkgs/hashPassword/default.nix
+++ /dev/null
@@ -1,15 +0,0 @@
-{ lib, pkgs, ... }:
-
-pkgs.writeDashBin "hashPassword" ''
- # usage: hashPassword
- set -euf
-
- export PATH=${lib.makeBinPath (with pkgs; [
- coreutils
- mkpasswd
- openssl
- ])}
-
- salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
- exec mkpasswd -m sha-512 -S "$salt"
-''