summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 1ff183e74..516648849 100644
--- a/flake.nix
+++ b/flake.nix
@@ -12,15 +12,17 @@
description = "stockholm";
outputs = { self, nixpkgs, nix-writers }: {
- nixosConfigurations.hotdog = nixpkgs.lib.nixosSystem {
+ nixosConfigurations = nixpkgs.lib.mapAttrs (machineName: _: nixpkgs.lib.nixosSystem {
system = "x86_64-linux";
specialArgs.stockholm = self;
specialArgs.nix-writers = nix-writers;
- specialArgs.secrets = toString ./krebs/0tests/data/secrets;
modules = [
- ./krebs/1systems/hotdog/config.nix
+ ./krebs/1systems/${machineName}/config.nix
+ {
+ krebs.secret.directory = "/var/src/secrets";
+ }
];
- };
+ }) (builtins.readDir ./krebs/1systems);
nixosModules =
let