summaryrefslogtreecommitdiffstats
path: root/1systems/tv/cd.nix
diff options
context:
space:
mode:
Diffstat (limited to '1systems/tv/cd.nix')
-rw-r--r--1systems/tv/cd.nix38
1 files changed, 11 insertions, 27 deletions
diff --git a/1systems/tv/cd.nix b/1systems/tv/cd.nix
index d3cae6f4a..6913508b5 100644
--- a/1systems/tv/cd.nix
+++ b/1systems/tv/cd.nix
@@ -7,13 +7,15 @@ let
in
{
+ krebs.build.host = config.krebs.hosts.cd;
+
imports = [
../../2configs/tv/CAC-Developer-2.nix
../../2configs/tv/CAC-CentOS-7-64bit.nix
../../2configs/tv/base.nix
../../2configs/tv/consul-server.nix
../../2configs/tv/exim-smarthost.nix
- ../../2configs/tv/git-public.nix
+ ../../2configs/tv/git.nix
{
imports = [ ../../2configs/tv/charybdis.nix ];
tv.charybdis = {
@@ -22,24 +24,17 @@ in
};
}
{
- imports = [ ../../3modules/tv/ejabberd.nix ];
tv.ejabberd = {
enable = true;
hosts = [ "jabber.viljetic.de" ];
};
}
{
- imports = [ ../../3modules/tv/github-hosts-sync.nix ];
- tv.github-hosts-sync.enable = true;
+ krebs.github-hosts-sync.enable = true;
tv.iptables.input-internet-accept-new-tcp =
- singleton config.tv.github-hosts-sync.port;
- }
- {
- imports = [ ../../2configs/tv/identity.nix ];
- tv.identity.self = config.tv.identity.hosts.cd;
+ singleton config.krebs.github-hosts-sync.port;
}
{
- imports = [ ../../3modules/tv/iptables.nix ];
tv.iptables = {
enable = true;
input-internet-accept-new-tcp = [
@@ -55,21 +50,13 @@ in
};
}
{
- imports = [
- ../../3modules/tv/iptables.nix
- ../../3modules/tv/nginx.nix
- ];
tv.iptables.input-internet-accept-new-tcp = singleton "http";
- tv.nginx.servers.cgit.server-names = singleton "cgit.cd.viljetic.de";
+ krebs.nginx.servers.cgit.server-names = singleton "cgit.cd.viljetic.de";
}
{
# TODO make public_html also available to cd, cd.retiolum (AKA default)
- imports = [
- ../../3modules/tv/iptables.nix
- ../../3modules/tv/nginx.nix
- ];
tv.iptables.input-internet-accept-new-tcp = singleton "http";
- tv.nginx.servers.public_html = {
+ krebs.nginx.servers.public_html = {
server-names = singleton "cd.viljetic.de";
locations = singleton (nameValuePair "~ ^/~(.+?)(/.*)?\$" ''
alias /home/$1/public_html$2;
@@ -77,7 +64,7 @@ in
};
}
{
- tv.nginx.servers.viljetic = {
+ krebs.nginx.servers.viljetic = {
server-names = singleton "viljetic.de";
# TODO directly set root (instead via location)
locations = singleton (nameValuePair "/" ''
@@ -86,10 +73,8 @@ in
};
}
{
- imports = [ ../../3modules/tv/retiolum.nix ];
- tv.retiolum = {
+ krebs.retiolum = {
enable = true;
- hosts = ../../Zhosts;
connectTo = [
"fastpoke"
"pigstarter"
@@ -99,7 +84,6 @@ in
}
];
- networking.hostName = "cd";
networking.interfaces.enp2s1.ip4 = [
{
address = "162.219.7.216";
@@ -135,8 +119,8 @@ in
home = "/home/mv";
createHome = true;
useDefaultShell = true;
- openssh.authorizedKeys.keys = map readFile [
- ../../Zpubkeys/mv_vod.ssh.pub
+ openssh.authorizedKeys.keys = [
+ config.krebs.users.mv.pubkey
];
};
};