summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-06-20 19:31:19 +0200
committerlassulus <lass@lassul.us>2017-06-20 19:31:19 +0200
commit915ccf6ee26688be9daf37a6083b91be95cae024 (patch)
tree18dd85796c90fe7898a2b3a8e8c505ea672598a3 /tv/2configs/vim.nix
parentfbabdb5081366e295fb10a2486fcc66e43a20ed1 (diff)
parenta9f4ad7586bfb543cdcdeacf93b71bdce506621a (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix27
1 files changed, 15 insertions, 12 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index b534c3f42..93ed46dc8 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -297,18 +297,21 @@ let {
alldirs = attrValues dirs ++ map dirOf (attrValues files);
in unique (sort lessThan alldirs);
- vim-wrapper = pkgs.concat "vim" [
- pkgs.vim_configurable
- (pkgs.writeDashBin "vim" ''
- set -efu
- (umask 0077; exec ${pkgs.coreutils}/bin/mkdir -p ${toString mkdirs})
- if test $# = 0 && test -e "$PWD/.ctrlpignore"; then
- set -- +CtrlP
- fi
- # vim-orgmode needs Python, thus vim_configurable instead of just vim
- exec ${pkgs.vim_configurable}/bin/vim "$@"
- '')
- ];
+ vim-wrapper = pkgs.symlinkJoin {
+ name = "vim";
+ paths = [
+ pkgs.vim_configurable
+ (pkgs.writeDashBin "vim" ''
+ set -efu
+ (umask 0077; exec ${pkgs.coreutils}/bin/mkdir -p ${toString mkdirs})
+ if test $# = 0 && test -e "$PWD/.ctrlpignore"; then
+ set -- +CtrlP
+ fi
+ # vim-orgmode needs Python, thus vim_configurable instead of just vim
+ exec ${pkgs.vim_configurable}/bin/vim "$@"
+ '')
+ ];
+ };
vimrc = pkgs.writeText "vimrc" ''
set nocompatible