summaryrefslogtreecommitdiffstats
path: root/tv/2configs/ppp.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-10-27 17:13:42 +0200
committerlassulus <lassulus@lassul.us>2017-10-27 17:13:42 +0200
commit233df9688fd7b08d15ad1f9f916c475d30fdc7ff (patch)
treeb396fdc88c9795572875366653e8cedd1ceb8ee5 /tv/2configs/ppp.nix
parentb6be4c6f40a699e7fd6032e5d33395aaa9c8c497 (diff)
parent36c01359dcffd3c7424366b9c43eb0b8baae666a (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'tv/2configs/ppp.nix')
-rw-r--r--tv/2configs/ppp.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/tv/2configs/ppp.nix b/tv/2configs/ppp.nix
new file mode 100644
index 000000000..9cc7568a5
--- /dev/null
+++ b/tv/2configs/ppp.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }: {
+
+ # usage: pppd call default
+
+ environment.etc."ppp/peers/default".text = ''
+ /dev/ttyACM2
+ 921600
+ crtscts
+ defaultroute
+ holdoff 10
+ lock
+ maxfail 0
+ noauth
+ nodetach
+ noipdefault
+ passive
+ persist
+ usepeerdns
+ connect "${pkgs.ppp}/bin/chat -f ${pkgs.writeText "default.chat" ''
+ ABORT "BUSY"
+ ABORT "NO CARRIER"
+ REPORT CONNECT
+ "" "ATDT*99#"
+ CONNECT
+ ''}"
+ '';
+
+ environment.systemPackages = [
+ pkgs.ppp
+ ];
+
+}