summaryrefslogtreecommitdiffstats
path: root/old/modules/lass/iptables/options.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-13 13:39:49 +0200
committerlassulus <lass@aidsballs.de>2015-07-16 15:47:28 +0200
commitd629bee9546fa6ed6a018f2b6d491a851ad12738 (patch)
tree049777923f431beab9b3fd0a5e1c3953f4418451 /old/modules/lass/iptables/options.nix
parent02261729c0a4108f2fcccf062b603d62f56782bf (diff)
"rebase"
Diffstat (limited to 'old/modules/lass/iptables/options.nix')
-rw-r--r--old/modules/lass/iptables/options.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/old/modules/lass/iptables/options.nix b/old/modules/lass/iptables/options.nix
new file mode 100644
index 000000000..eb3bfc011
--- /dev/null
+++ b/old/modules/lass/iptables/options.nix
@@ -0,0 +1,44 @@
+{ lib, ... }:
+
+let
+ inherit (lib) mkEnableOption mkOption types;
+in
+
+{
+ enable = mkEnableOption "iptables";
+
+ #tables.filter.INPUT = {
+ # policy = "DROP";
+ # rules = [
+ # { predicate = "-i retiolum"; target = "ACCEPT"; priority = -10; }
+ # ];
+ #};
+ #new api
+ tables = mkOption {
+ type = with types; attrsOf (attrsOf (submodule ({
+ options = {
+ policy = mkOption {
+ type = str;
+ default = "-";
+ };
+ rules = mkOption {
+ type = nullOr (listOf (submodule ({
+ options = {
+ predicate = mkOption {
+ type = str;
+ };
+ target = mkOption {
+ type = str;
+ };
+ precedence = mkOption {
+ type = int;
+ default = 0;
+ };
+ };
+ })));
+ default = null;
+ };
+ };
+ })));
+ };
+}
[cgit] Unable to lock slot /tmp/cgit/13200000.lock: No such file or directory (2)