summaryrefslogtreecommitdiffstats
path: root/modules/tv/nginx/options.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-22 18:20:25 +0200
committertv <tv@shackspace.de>2015-06-22 18:20:25 +0200
commit964855f30bcb36869f24cb8474b9a0c44f58a736 (patch)
tree1056515620276960498f3c7455624802d6173620 /modules/tv/nginx/options.nix
parentf2c8dbe4d126501e271e58c8a3ee3130c46dc0b9 (diff)
tv: modularize nginx
Diffstat (limited to 'modules/tv/nginx/options.nix')
-rw-r--r--modules/tv/nginx/options.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/tv/nginx/options.nix b/modules/tv/nginx/options.nix
new file mode 100644
index 000000000..ddfb38049
--- /dev/null
+++ b/modules/tv/nginx/options.nix
@@ -0,0 +1,21 @@
+{ lib, ... }:
+
+let
+ inherit (lib) mkOption types;
+in
+
+{
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ description = "Enable nginx.";
+ };
+
+ retiolum-locations = mkOption {
+ type = with types; listOf (attrsOf str);
+ default = [];
+ description = ''
+ TODO
+ '';
+ };
+}
[cgit] Unable to lock slot /tmp/cgit/cf200000.lock: No such file or directory (2)