summaryrefslogtreecommitdiffstats
path: root/modules/mkdir/users.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-19 21:59:27 +0200
committertv <tv@shackspace.de>2015-06-19 21:59:27 +0200
commite5b14a9ed69a75f57a2184f85f5b4f24cb50da51 (patch)
tree8bfd22f9ac2cf0037e930a9b0ee98f4be67e5f49 /modules/mkdir/users.nix
parentf98ab8ec7e531fc0e33d67ca4624ac431eb7f753 (diff)
host mkdir: initial commit
Diffstat (limited to 'modules/mkdir/users.nix')
-rw-r--r--modules/mkdir/users.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/mkdir/users.nix b/modules/mkdir/users.nix
new file mode 100644
index 000000000..82f078b4e
--- /dev/null
+++ b/modules/mkdir/users.nix
@@ -0,0 +1,19 @@
+{ ... }:
+
+let
+ inherit (builtins) readFile;
+in
+
+{
+ users.extraUsers =
+ {
+ root = {
+ openssh.authorizedKeys.keys = [
+ (readFile <pubkeys/deploy_wu.ssh.pub>)
+ (readFile <pubkeys/tv_wu.ssh.pub>)
+ ];
+ };
+ };
+
+ users.mutableUsers = false;
+}
[cgit] Unable to lock slot /tmp/cgit/37000000.lock: No such file or directory (2)