summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/vm-single-partition.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-08-13 22:36:07 +0200
committerlassulus <lass@aidsballs.de>2015-08-13 22:36:07 +0200
commitcc1baf4d385e45b8c9f0509c04e8883f48ade6ae (patch)
tree9eb6a04cdb91414d662409e7f8b3b2e396f92895 /makefu/2configs/vm-single-partition.nix
parentdbd69c4e956bc1c88b379c273a5ea5b4ceea8813 (diff)
parentdb4b55527d527158bd4e7f93128668e646f2cf1f (diff)
Merge branch 'tv' into newmaster
Diffstat (limited to 'makefu/2configs/vm-single-partition.nix')
-rw-r--r--makefu/2configs/vm-single-partition.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/2configs/vm-single-partition.nix b/makefu/2configs/vm-single-partition.nix
new file mode 100644
index 000000000..78a5e7175
--- /dev/null
+++ b/makefu/2configs/vm-single-partition.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+# vda1 ext4 (label nixos) -> only root partition
+with lib;
+{
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/vda";
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-label/nixos";
+ fsType = "ext4";
+ };
+
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+
+}