summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/sda-crypto-root-home.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-08-28 21:54:35 +0200
committertv <tv@shackspace.de>2015-08-28 21:54:35 +0200
commite5ecd75ac266a77c31790e52c2ea000574be9e22 (patch)
treeeecdc35c4a8f257d86178f6eb864c9404a2f1aa7 /makefu/2configs/sda-crypto-root-home.nix
parent62865ae6ae46e006cea7ee80b931fc5be27d3449 (diff)
parentecae9b59753c13ea5bff57a6f7c44086c77844d6 (diff)
Merge remote-tracking branch 'uriel/master'
Diffstat (limited to 'makefu/2configs/sda-crypto-root-home.nix')
-rw-r--r--makefu/2configs/sda-crypto-root-home.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/makefu/2configs/sda-crypto-root-home.nix b/makefu/2configs/sda-crypto-root-home.nix
new file mode 100644
index 000000000..3821c7504
--- /dev/null
+++ b/makefu/2configs/sda-crypto-root-home.nix
@@ -0,0 +1,39 @@
+{ config, lib, pkgs, ... }:
+
+# ssd #
+# sda: bootloader grub2
+# sda1: boot ext4 (label nixboot)
+# sda2: cryptoluks -> lvm:
+# / (main-root)
+# /home (main-home)
+
+with lib;
+{
+ boot = {
+ loader.grub.enable =true;
+ loader.grub.version =2;
+ loader.grub.device = "/dev/sda";
+
+ initrd.luks.devices = [ { name = "main"; device = "/dev/sda2"; allowDiscards=true; }];
+ initrd.luks.cryptoModules = ["aes" "sha512" "sha1" "xts" ];
+ initrd.availableKernelModules = ["xhci_hcd" "ehci_pci" "ahci" "usb_storage" ];
+ };
+ fileSystems = {
+ "/" = {
+ device = "/dev/mapper/main-root";
+ fsType = "ext4";
+ options="defaults,discard";
+ };
+ # TODO: just import sda-crypto-root, add this device
+ "/home" = {
+ device = "/dev/mapper/main-home";
+ fsType = "ext4";
+ options="defaults,discard";
+ };
+ "/boot" = {
+ device = "/dev/disk/by-label/nixboot";
+ fsType = "ext4";
+ options="defaults,discard";
+ };
+ };
+}