summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/graphite-standalone.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-08-13 22:36:07 +0200
committerlassulus <lass@aidsballs.de>2015-08-13 22:36:07 +0200
commitcc1baf4d385e45b8c9f0509c04e8883f48ade6ae (patch)
tree9eb6a04cdb91414d662409e7f8b3b2e396f92895 /makefu/2configs/graphite-standalone.nix
parentdbd69c4e956bc1c88b379c273a5ea5b4ceea8813 (diff)
parentdb4b55527d527158bd4e7f93128668e646f2cf1f (diff)
Merge branch 'tv' into newmaster
Diffstat (limited to 'makefu/2configs/graphite-standalone.nix')
-rw-r--r--makefu/2configs/graphite-standalone.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/makefu/2configs/graphite-standalone.nix b/makefu/2configs/graphite-standalone.nix
new file mode 100644
index 000000000..8b70c11c8
--- /dev/null
+++ b/makefu/2configs/graphite-standalone.nix
@@ -0,0 +1,34 @@
+{ config, lib, pkgs, ... }:
+
+# graphite-web on port 8080
+# carbon cache on port 2003 (tcp/udp)
+with lib;
+{
+ imports = [ ];
+
+ services.graphite = {
+ web = {
+ enable = true;
+ host = "0.0.0.0";
+ };
+ carbon = {
+ enableCache = true;
+ # save disk usage by restricting to 1 bulk update per second
+ config = ''
+ [cache]
+ MAX_CACHE_SIZE = inf
+ MAX_UPDATES_PER_SECOND = 1
+ MAX_CREATES_PER_MINUTE = 50
+ '';
+ storageSchemas = ''
+ [carbon]
+ pattern = ^carbon\.
+ retentions = 60:90d
+
+ [default]
+ pattern = .*
+ retentions = 60s:30d,300s:1y
+ '';
+ };
+ };
+}