summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/nextgum/hardware-config.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-08-21 19:52:30 +0200
committerjeschli <jeschli@gmail.com>2018-08-21 19:52:30 +0200
commit8cfc4f5eda10b1025a4ad3b9725deb9ad7a32338 (patch)
tree4a9626e685bc076461f5e63c55e29e3689d2eedd /makefu/1systems/nextgum/hardware-config.nix
parentf2dadea808323f69531c51b12ed5cb872ac933a0 (diff)
parent89951ebd816248bc4e62b2dad78b5db906c3cefe (diff)
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'makefu/1systems/nextgum/hardware-config.nix')
-rw-r--r--makefu/1systems/nextgum/hardware-config.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/makefu/1systems/nextgum/hardware-config.nix b/makefu/1systems/nextgum/hardware-config.nix
index 36fea6544..944210701 100644
--- a/makefu/1systems/nextgum/hardware-config.nix
+++ b/makefu/1systems/nextgum/hardware-config.nix
@@ -45,12 +45,20 @@ in {
"ata_piix" "vmw_pvscsi" "virtio_pci" "sd_mod" "ahci"
"xhci_pci" "ehci_pci" "ahci" "sd_mod"
];
- boot.kernelModules = [ "kvm-intel" ];
+ boot.kernelModules = [ "kvm-intel" "dm-raid" "dm_thin_pool" ];
hardware.enableRedistributableFirmware = true;
fileSystems."/" = {
device = "/dev/mapper/nixos-root";
fsType = "ext4";
};
+ fileSystems."/var/lib" = {
+ device = "/dev/mapper/nixos-lib";
+ fsType = "ext4";
+ };
+ fileSystems."/var/download" = {
+ device = "/dev/mapper/nixos-download";
+ fsType = "ext4";
+ };
fileSystems."/boot" = {
device = "/dev/sda2";
fsType = "vfat";
@@ -69,7 +77,9 @@ in {
#pvcreate /dev/sda3
#pvcreate /dev/sdb1
#vgcreate nixos /dev/sda3 /dev/sdb1
- #lvcreate -L 120G -n root nixos
+ #lvcreate -L 120G -m 1 -n root nixos
+ #lvcreate -L 50G -m 1 -n lib nixos
+ #lvcreate -L 50G -n download nixos
#mkfs.ext4 /dev/mapper/nixos-root
#mount /dev/mapper/nixos-root /mnt
#mkdir /mnt/boot