summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/filepimp.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-11-06 11:01:49 +0100
committermakefu <github@syntax-fehler.de>2015-11-06 11:01:59 +0100
commit2dcb2918d1cd159d9282096ef3b5cecc4239bfbc (patch)
treee2f9b6dab9b2b8e366156381887762d22f7021ba /makefu/1systems/filepimp.nix
parente8ad43c082e54151517c45c4825e31354803e4c8 (diff)
m 1,2: refactor, remove overhead for fs/hw, add filepimp
Diffstat (limited to 'makefu/1systems/filepimp.nix')
-rw-r--r--makefu/1systems/filepimp.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/makefu/1systems/filepimp.nix b/makefu/1systems/filepimp.nix
new file mode 100644
index 000000000..fabecec83
--- /dev/null
+++ b/makefu/1systems/filepimp.nix
@@ -0,0 +1,41 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ ../2configs/base.nix
+ ../2configs/fs/vm-single-partition.nix
+ ../2configs/fs/single-partition-ext4.nix
+ ../2configs/tinc-basic-retiolum.nix
+ ../2configs/base-sources.nix
+ ];
+ krebs.build.host = config.krebs.hosts.filepimp;
+ krebs.build.user = config.krebs.users.makefu;
+ krebs.build.target = "root@filepimp";
+
+ # AMD N54L
+ boot = {
+ loader.grub.device = "/dev/sda";
+
+ initrd.availableKernelModules = [
+ "usb_storage"
+ "ahci"
+ "xhci_hcd"
+ "ata_piix"
+ "uhci_hcd"
+ "ehci_pci"
+ ];
+
+ kernelModules = [ ];
+ extraModulePackages = [ ];
+ };
+
+ hardware.enableAllFirmware = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+ networking.firewall.allowPing = true;
+}
[cgit] Unable to lock slot /tmp/cgit/4e100000.lock: No such file or directory (2)