summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-12-05 18:46:48 +0100
committerlassulus <lassulus@lassul.us>2017-12-05 18:46:48 +0100
commit8030352c450432a0cee14f561241831875f8399b (patch)
tree832fc539497da14ec7d90e1540cb8093ca63cfbd /lib/types.nix
parent18fad9c618be468d3a8e902ee2e23143e598163c (diff)
parent704096c93e91f0b71d257028401b52d6da03c073 (diff)
Merge branch 'prism/master' into HEAD
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 08dc0974e..c3b14d807 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -92,7 +92,7 @@ rec {
default = null;
};
addrs = mkOption {
- type = listOf cidr;
+ type = listOf addr;
default =
optional (config.ip4 != null) config.ip4.addr ++
optional (config.ip6 != null) config.ip6.addr;
@@ -155,6 +155,8 @@ rec {
++
(map (a: "Subnet = ${a}") net.addrs)
++
+ (map (a: "Subnet = ${a}") config.subnets)
+ ++
[config.extraConfig]
++
[config.pubkey]
@@ -173,6 +175,11 @@ rec {
description = "tinc port to use to connect to host";
default = 655;
};
+ subnets = mkOption {
+ type = listOf cidr;
+ description = "tinc subnets";
+ default = [];
+ };
};
}));
default = null;