summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-08 13:33:48 +0100
committermakefu <github@syntax-fehler.de>2017-12-08 13:33:48 +0100
commit3faa41106961e7a52e9400be23cdf10b64f4932c (patch)
treeccd6b4f1fea4b58484440da6f613ddbf55b3fe92 /lib/types.nix
parent04e6eeb7c8e2e3141293a84bc147265725208999 (diff)
parenta9b72bd2901ca232eb7b6523c535c593a36521ef (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 08dc0974e..c3b14d807 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -92,7 +92,7 @@ rec {
default = null;
};
addrs = mkOption {
- type = listOf cidr;
+ type = listOf addr;
default =
optional (config.ip4 != null) config.ip4.addr ++
optional (config.ip6 != null) config.ip6.addr;
@@ -155,6 +155,8 @@ rec {
++
(map (a: "Subnet = ${a}") net.addrs)
++
+ (map (a: "Subnet = ${a}") config.subnets)
+ ++
[config.extraConfig]
++
[config.pubkey]
@@ -173,6 +175,11 @@ rec {
description = "tinc port to use to connect to host";
default = 655;
};
+ subnets = mkOption {
+ type = listOf cidr;
+ description = "tinc subnets";
+ default = [];
+ };
};
}));
default = null;
[cgit] Unable to lock slot /tmp/cgit/b5200000.lock: No such file or directory (2)