summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2022-01-06 13:18:48 +0100
committermakefu <github@syntax-fehler.de>2022-01-06 13:18:48 +0100
commitfe0e878c1fa9ae749aaf5c3169994118794f152b (patch)
tree6b6e1f22f803830bde9266f6afc96985d5eb12c3 /lib/default.nix
parentdfe5f39dabb7626804e29797c51ac0df87656129 (diff)
parentdeda4c978956e39c3b6345e5ef5604b2bc020e00 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 574713e48..94a81439e 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -52,6 +52,7 @@ let
type = typeOf x;
reject = throw "cannot convert ${type}";
in {
+ int = toJSON x; # close enough
list = "{ ${concatStringsSep ", " (map toC x)} }";
null = "NULL";
set = if isDerivation x then toJSON x else reject;