summaryrefslogtreecommitdiffstats
path: root/lass/2configs/bitcoin.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-09-11 14:55:04 +0200
committertv <tv@krebsco.de>2023-09-11 14:55:04 +0200
commit8fc162ee3d9525a2b45346a1ca8f34ccb5ef971b (patch)
treeaa37724dd0452860d4b9b033332587c8832629e3 /lass/2configs/bitcoin.nix
parent90b1515dcd5b67a85cd92901fb211764b1fa5f83 (diff)
parent083229d0211096daec08673f743ccc45b1d8a0ac (diff)
Merge remote-tracking branch 'orange/master'
Diffstat (limited to 'lass/2configs/bitcoin.nix')
-rw-r--r--lass/2configs/bitcoin.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/lass/2configs/bitcoin.nix b/lass/2configs/bitcoin.nix
deleted file mode 100644
index e9dd055f9..000000000
--- a/lass/2configs/bitcoin.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- mainUser = config.users.extraUsers.mainUser;
-in {
-
- users.extraUsers = {
- bitcoin = {
- name = "bitcoin";
- description = "user for bitcoin stuff";
- home = "/home/bitcoin";
- useDefaultShell = true;
- createHome = true;
- packages = [ pkgs.electrum ];
- isNormalUser = true;
- };
- monero = {
- name = "monero";
- description = "user for monero stuff";
- home = "/home/monero";
- useDefaultShell = true;
- createHome = true;
- packages = [
- pkgs.monero
- pkgs.monero-gui
- ];
- isNormalUser = true;
- };
- };
- security.sudo.extraConfig = ''
- ${mainUser.name} ALL=(bitcoin) ALL
- ${mainUser.name} ALL=(monero) ALL
- '';
-}