summaryrefslogtreecommitdiffstats
path: root/lass/2configs/ableton.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-01-04 00:21:13 +0100
committermakefu <github@syntax-fehler.de>2018-01-04 00:21:13 +0100
commit8c6bd7431c8620fa65466e880fbd38e2c555367d (patch)
tree9d73f67cf751a6f3f99b6a5a0c3dd0ddaee16382 /lass/2configs/ableton.nix
parent6ad170e7621668fdcf03aab37d1f9843e446d2da (diff)
parenta9f803207243425d5c06ce82820c27a4de8af5ad (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/2configs/ableton.nix')
-rw-r--r--lass/2configs/ableton.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/lass/2configs/ableton.nix b/lass/2configs/ableton.nix
new file mode 100644
index 000000000..9d6f481b0
--- /dev/null
+++ b/lass/2configs/ableton.nix
@@ -0,0 +1,20 @@
+{ config, pkgs, ... }: let
+ mainUser = config.users.extraUsers.mainUser;
+in {
+ users.users= {
+ ableton = {
+ isNormalUser = true;
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ packages = [
+ pkgs.wine
+ pkgs.winetricks
+ ];
+ };
+ };
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(ableton) NOPASSWD: ALL
+ '';
+}