summaryrefslogtreecommitdiffstats
path: root/lass/1systems/mors.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-12-25 00:33:39 +0100
committermakefu <github@syntax-fehler.de>2016-12-25 00:33:39 +0100
commit47ade5b208c2fa2a1c4b96cbe753d2889a9da55e (patch)
treebfb13112f8d449e72693959830f8491190fabf81 /lass/1systems/mors.nix
parent3682e60aee26578f3163920b9feab641b21f5e5c (diff)
parent1d2c9377bc7b21ff7d27c6c04873a46df083d655 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/1systems/mors.nix')
-rw-r--r--lass/1systems/mors.nix18
1 files changed, 13 insertions, 5 deletions
diff --git a/lass/1systems/mors.nix b/lass/1systems/mors.nix
index 594f342db..4553cc15b 100644
--- a/lass/1systems/mors.nix
+++ b/lass/1systems/mors.nix
@@ -68,11 +68,19 @@ with import <stockholm/lib>;
{
krebs.nginx = {
enable = true;
- servers.default.locations = [
- (nameValuePair "~ ^/~(.+?)(/.*)?\$" ''
- alias /home/$1/public_html$2;
- '')
- ];
+ servers.default = {
+ server-names = [
+ "localhost"
+ "${config.krebs.build.host.name}"
+ "${config.krebs.build.host.name}.r"
+ "${config.krebs.build.host.name}.retiolum"
+ ];
+ locations = [
+ (nameValuePair "~ ^/~(.+?)(/.*)?\$" ''
+ alias /home/$1/public_html$2;
+ '')
+ ];
+ };
};
}
{