summaryrefslogtreecommitdiffstats
path: root/lass/1systems/helios/config.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-12-27 17:09:35 +0100
committertv <tv@krebsco.de>2017-12-27 17:09:35 +0100
commit6ed214fc77b537dc74b92bbc37e2d2d68dfd9131 (patch)
tree97e0ca20812fa54edfa0bd60460800ff2f18626e /lass/1systems/helios/config.nix
parent04b711f516c978e84b334a82008d40dfaad1de1b (diff)
parent3a41a73f1fcc32736ace08783d9bfee8a77f3f80 (diff)
Merge remote-tracking branch 'prism/staging/test'
Diffstat (limited to 'lass/1systems/helios/config.nix')
-rw-r--r--lass/1systems/helios/config.nix33
1 files changed, 21 insertions, 12 deletions
diff --git a/lass/1systems/helios/config.nix b/lass/1systems/helios/config.nix
index b14ef2a3e..8bd9735a9 100644
--- a/lass/1systems/helios/config.nix
+++ b/lass/1systems/helios/config.nix
@@ -20,20 +20,26 @@ with import <stockholm/lib>;
boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
boot.kernelModules = [ "kvm-intel" ];
- fileSystems."/" =
- { device = "/dev/pool/root";
- fsType = "btrfs";
- };
+ fileSystems."/" = {
+ device = "/dev/pool/root";
+ fsType = "btrfs";
+ };
+
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/1F60-17C6";
+ fsType = "vfat";
+ };
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/1F60-17C6";
- fsType = "vfat";
- };
+ fileSystems."/home" = {
+ device = "/dev/pool/home";
+ fsType = "btrfs";
+ };
- fileSystems."/home" =
- { device = "/dev/pool/home";
- fsType = "btrfs";
- };
+ fileSystems."/tmp" = {
+ device = "tmpfs";
+ fsType = "tmpfs";
+ options = ["nosuid" "nodev" "noatime"];
+ };
nix.maxJobs = lib.mkDefault 8;
}
@@ -150,4 +156,7 @@ with import <stockholm/lib>;
services.printing.drivers = [ pkgs.postscript-lexmark ];
+ services.logind.extraConfig = ''
+ HandleLidSwitch=ignore
+ '';
}