summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/quote.nix
diff options
context:
space:
mode:
authornin <nineinchnade@gmail.com>2017-10-17 21:37:13 +0200
committernin <nineinchnade@gmail.com>2017-10-17 21:37:13 +0200
commit10850a202732728f4b95da7208005617606c2062 (patch)
treec3d506a70fc715369b42dfc31849c7155f035c6a /krebs/5pkgs/simple/quote.nix
parent9afe5210f2a44cacac4f3527b6c8b561d9e4296b (diff)
parent9af86e7134ae2f134bc93baf5d0332ad2a77f9f9 (diff)
Merge remote-tracking branch 'temp/master'
Diffstat (limited to 'krebs/5pkgs/simple/quote.nix')
-rw-r--r--krebs/5pkgs/simple/quote.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/quote.nix b/krebs/5pkgs/simple/quote.nix
new file mode 100644
index 000000000..7731e14bf
--- /dev/null
+++ b/krebs/5pkgs/simple/quote.nix
@@ -0,0 +1,13 @@
+{ jq, writeDashBin }:
+
+# usage: quote [ARGS...]
+writeDashBin "quote" ''
+ set -efu
+ prefix=
+ for x; do
+ y=$(${jq}/bin/jq -nr --arg x "$x" '$x | @sh "\(.)"')
+ echo -n "$prefix$y"
+ prefix=' '
+ done
+ echo
+''