summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/pssh/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-06-01 10:08:56 +0200
committermakefu <github@syntax-fehler.de>2017-06-01 10:08:56 +0200
commit772f84305d90380e0d221cf49ae3f1597d0d0510 (patch)
tree8d2241648396dc34fa96c8c68e12f832fbc7c308 /krebs/5pkgs/simple/pssh/default.nix
parent90822f64e0bf247c5cca2f035077553cac5ceb79 (diff)
parent21d92086fe00c7369fde3951f92e9f73f4c05ee9 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'krebs/5pkgs/simple/pssh/default.nix')
-rw-r--r--krebs/5pkgs/simple/pssh/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/pssh/default.nix b/krebs/5pkgs/simple/pssh/default.nix
new file mode 100644
index 000000000..2676af0cf
--- /dev/null
+++ b/krebs/5pkgs/simple/pssh/default.nix
@@ -0,0 +1,36 @@
+{ writeDashBin }:
+
+writeDashBin "pssh" ''
+ set -efu
+ case ''${1-} in
+
+ # TODO create plog with -o json | jq ... | map date
+
+ # usage: pssh {-j,--journal} host...
+ # Follow journal at each host.
+ -j|--journal)
+ shift
+ "$0" journalctl -n0 -ocat --follow --all ::: "$@" \
+ | while read line; do
+ printf '%s %s\n' "$(date --rfc-3339=s)" "$line"
+ done
+ ;;
+
+ -*)
+ echo $0: unknown option: $1 >&2
+ exit 1
+ ;;
+
+ # usage: pssh command [arg...] ::: host...
+ # Run command at each host.
+ *)
+ exec parallel \
+ --line-buffer \
+ -j0 \
+ --no-notice \
+ --tagstring {} \
+ ssh -T {} "$@"
+ ;;
+
+ esac
+''