summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/tinc_graphs.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-10-31 00:14:35 +0100
committerlassulus <lass@aidsballs.de>2015-10-31 00:14:35 +0100
commit10779f3cb9b7e00aac50faa98adbd2ebd9a675a0 (patch)
tree7aef8997e959c346cb9ae61f7bc1626a8c5bb473 /krebs/3modules/tinc_graphs.nix
parent5b4a34062462311973bb1798fe3e4538e6eb5706 (diff)
parent546469e18d24252360279ea276eb9a502670c712 (diff)
Merge remote-tracking branch 'pnp/master'
Diffstat (limited to 'krebs/3modules/tinc_graphs.nix')
-rw-r--r--krebs/3modules/tinc_graphs.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/krebs/3modules/tinc_graphs.nix b/krebs/3modules/tinc_graphs.nix
index a6c628353..e415d20ab 100644
--- a/krebs/3modules/tinc_graphs.nix
+++ b/krebs/3modules/tinc_graphs.nix
@@ -95,8 +95,12 @@ let
ExecStartPre = pkgs.writeScript "tinc_graphs-init" ''
#!/bin/sh
+ mkdir -p "${internal_dir}" "${external_dir}"
if ! test -e "${cfg.workingDir}/internal/index.html"; then
- cp -fr "$(${pkgs.tinc_graphs}/bin/tincstats-static-dir)/internal/" "${internal_dir}"
+ cp -fr "$(${pkgs.tinc_graphs}/bin/tincstats-static-dir)/internal/." "${internal_dir}"
+ fi
+ if ! test -e "${cfg.workingDir}/external/index.html"; then
+ cp -fr "$(${pkgs.tinc_graphs}/bin/tincstats-static-dir)/external/." "${external_dir}"
fi
'';
@@ -118,7 +122,6 @@ let
users.extraUsers.tinc_graphs = {
uid = 3925439960; #genid tinc_graphs
home = "/var/spool/tinc_graphs";
- createHome = true;
};
krebs.nginx.servers = mkIf cfg.nginx.enable {