summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/git.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-02-16 17:15:00 +0100
committerlassulus <lass@aidsballs.de>2016-02-16 17:15:00 +0100
commit0b0b0d65ee05583529df831985580e392713d29a (patch)
tree7eb6799a996924d8e895c54633a47ea3d7a92a4c /krebs/3modules/git.nix
parent3d30e9cc9014ec6189410944015d3cd7d5ca95a6 (diff)
parentb7a92f63884af00eb0243ec9328be689a6c9b845 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/3modules/git.nix')
-rw-r--r--krebs/3modules/git.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/krebs/3modules/git.nix b/krebs/3modules/git.nix
index 11cf21b5f..a9542718d 100644
--- a/krebs/3modules/git.nix
+++ b/krebs/3modules/git.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, lib, ... }:
+{ config, lib, pkgs, ... }:
# TODO unify logging of shell scripts to user and journal
# TODO move all scripts to ${etcDir}, so ControlMaster connections
@@ -6,13 +6,13 @@
# TODO when authorized_keys changes, then restart ssh
# (or kill already connected users somehow)
-with lib;
+with config.krebs.lib;
let
cfg = config.krebs.git;
out = {
options.krebs.git = api;
- config = mkIf cfg.enable (mkMerge [
+ config = with lib; mkIf cfg.enable (mkMerge [
(mkIf cfg.cgit cgit-imp)
git-imp
]);
@@ -86,7 +86,7 @@ let
singleton {
user = [ config.krebs.users.tv ];
repo = [ testing ]; # see literal example of repos
- perm = push "refs/*" (with lib.git; [
+ perm = push "refs/*" (with config.krebs.lib.git; [
non-fast-forward create delete merge
]);
}