summaryrefslogtreecommitdiffstats
path: root/4lib/krebs/types.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-28 21:38:22 +0200
committertv <tv@shackspace.de>2015-07-28 21:38:22 +0200
commit06cb4d25ef40773e2cc516e50a9aeec6cbe1d0a8 (patch)
treee05d849f048473aa9c90dc81b09d3a30dbe28ccc /4lib/krebs/types.nix
parent060087fab989a2cf362928c471ac8fd9c4d95c1e (diff)
*/krebs -> krebs/*
Diffstat (limited to '4lib/krebs/types.nix')
-rw-r--r--4lib/krebs/types.nix109
1 files changed, 0 insertions, 109 deletions
diff --git a/4lib/krebs/types.nix b/4lib/krebs/types.nix
deleted file mode 100644
index 92410dd58..000000000
--- a/4lib/krebs/types.nix
+++ /dev/null
@@ -1,109 +0,0 @@
-{ lib, ... }:
-
-with lib;
-with types;
-
-types // rec {
-
- host = submodule {
- options = {
- name = mkOption {
- type = label;
- };
- dc = mkOption {
- type = label;
- };
- cores = mkOption {
- type = positive;
- };
- nets = mkOption {
- type = attrsOf net;
- apply = x: assert hasAttr "retiolum" x; x;
- };
- secure = mkOption {
- type = bool;
- default = false;
- description = ''
- If true, then the host is capable of keeping secret information.
-
- TODO define minimum requirements for secure hosts
- '';
- };
- };
- };
-
- net = submodule ({ config, ... }: {
- options = {
- via = mkOption {
- type = nullOr net;
- default = null;
- };
- addrs = mkOption {
- type = listOf addr;
- apply = _: config.addrs4 ++ config.addrs6;
- };
- addrs4 = mkOption {
- type = listOf addr4;
- default = [];
- };
- addrs6 = mkOption {
- type = listOf addr6;
- default = [];
- };
- aliases = mkOption {
- # TODO nonEmptyListOf hostname
- type = listOf hostname;
- };
- tinc = mkOption {
- type = let net-config = config; in nullOr (submodule ({ config, ... }: {
- options = {
- config = mkOption {
- type = str;
- apply = _: ''
- ${optionalString (net-config.via != null)
- (concatMapStringsSep "\n" (a: "Address = ${a}") net-config.via.addrs)}
- ${concatMapStringsSep "\n" (a: "Subnet = ${a}") net-config.addrs}
- ${config.pubkey}
- '';
- };
- pubkey = mkOption {
- type = str;
- };
- };
- }));
- default = null;
- };
- };
- });
-
- positive = mkOptionType {
- name = "positive integer";
- check = x: isInt x && x > 0;
- merge = mergeOneOption;
- };
-
- user = submodule {
- options = {
- mail = mkOption {
- type = str; # TODO retiolum mail address
- };
- name = mkOption {
- type = str; # TODO
- };
- pubkey = mkOption {
- type = str;
- };
- pubkeys = mkOption {
- type = attrsOf str;
- default = {};
- };
- };
- };
-
- # TODO
- addr = str;
- addr4 = str;
- addr6 = str;
- hostname = str;
- label = str;
-}
[cgit] Unable to lock slot /tmp/cgit/64100000.lock: No such file or directory (2)