summaryrefslogtreecommitdiffstats
path: root/4lib/krebs/dns.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-26 21:04:13 +0200
committertv <tv@shackspace.de>2015-07-26 21:13:50 +0200
commit98bc5991db76171ae9e1631b66f41061420624db (patch)
tree6ed126f57257c467d9a7414512c83e891bcd626c /4lib/krebs/dns.nix
parent4926abb00f74614e7748b8959b8d2fcd8e98dacc (diff)
3 krebs: make dns.providers part of api
Diffstat (limited to '4lib/krebs/dns.nix')
-rw-r--r--4lib/krebs/dns.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/4lib/krebs/dns.nix b/4lib/krebs/dns.nix
new file mode 100644
index 000000000..b2cf3c24c
--- /dev/null
+++ b/4lib/krebs/dns.nix
@@ -0,0 +1,31 @@
+{ lib, ... }:
+
+let
+ listset = import ./listset.nix { inherit lib; };
+in
+
+with builtins;
+with lib;
+
+rec {
+ # label = string
+
+ # TODO does it make sense to have alias = list label?
+
+ # split-by-provider :
+ # [[label]] -> tree label provider -> listset provider alias
+ split-by-provider = as: providers:
+ foldl (m: a: listset.insert (provider-of a providers) a m) {} as;
+
+ # provider-of : alias -> tree label provider -> provider
+ # Note that we cannot use tree.get here, because path can be longer
+ # than the tree depth.
+ provider-of = a:
+ let
+ go = path: tree:
+ if typeOf tree == "string"
+ then tree
+ else go (tail path) tree.${head path};
+ in
+ go (reverseList (splitString "." a));
+}
[cgit] Unable to lock slot /tmp/cgit/81300000.lock: No such file or directory (2)