summaryrefslogtreecommitdiffstats
path: root/3modules/tv/nginx.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-24 11:50:23 +0200
committertv <tv@shackspace.de>2015-07-24 11:51:06 +0200
commit734ec4ae00c93d48297b7c3ee226ef890187bfa3 (patch)
treed0506e38317e9be22fcfd7ef283602e70b343bb6 /3modules/tv/nginx.nix
parent7846e26f8660b58d67eb90a21e7249715f49ac89 (diff)
3 {tv -> krebs}.nginx
Diffstat (limited to '3modules/tv/nginx.nix')
-rw-r--r--3modules/tv/nginx.nix71
1 files changed, 0 insertions, 71 deletions
diff --git a/3modules/tv/nginx.nix b/3modules/tv/nginx.nix
deleted file mode 100644
index a58c49520..000000000
--- a/3modules/tv/nginx.nix
+++ /dev/null
@@ -1,71 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-with builtins;
-with lib;
-let
- cfg = config.tv.nginx;
-
- out = {
- options.tv.nginx = api;
- config = mkIf cfg.enable imp;
- };
-
- api = {
- enable = mkEnableOption "tv.nginx";
-
- servers = mkOption {
- type = with types; attrsOf optionSet;
- options = singleton {
- server-names = mkOption {
- type = with types; listOf str;
- default = [
- "${config.networking.hostName}"
- "${config.networking.hostName}.retiolum"
- ];
- };
- locations = mkOption {
- type = with types; listOf (attrsOf str);
- };
- };
- default = {};
- };
- };
-
- imp = {
- services.nginx = {
- enable = true;
- httpConfig = ''
- include ${pkgs.nginx}/conf/mime.types;
- default_type application/octet-stream;
- sendfile on;
- keepalive_timeout 65;
- gzip on;
- server {
- listen 80 default_server;
- server_name _;
- return 404;
- }
- ${concatStrings (mapAttrsToList (_: to-server) cfg.servers)}
- '';
- };
- };
-
-
- indent = replaceChars ["\n"] ["\n "];
-
- to-location = { name, value }: ''
- location ${name} {
- ${indent value}
- }
- '';
-
- to-server = { server-names, locations, ... }: ''
- server {
- listen 80;
- server_name ${toString server-names};
- ${indent (concatStrings (map to-location locations))}
- }
- '';
-
-in
-out
[cgit] Unable to lock slot /tmp/cgit/4a200000.lock: No such file or directory (2)